GG51 Crash due to bot_quota

Having problems with GunGame5 (NOT FOR BUGS)? Ask here!

GG51 Crash due to bot_quota

Postby omnom » Thu Aug 15, 2013 12:34 am

Hello,

My server is crashing when bot_quota is used. The crash occurs if I use bot_quota in any of the various CFGs, or simply run rcon bot_quota <#> with in-game console, which is what I have been testing it with. If GG is not running, bots work fine.

I am running base installs of the following:

Name: EventScripts Public Beta v2.1.1.379
URL: http://forums.eventscripts.com/viewtopi ... 28&t=40765

Name: [12. Apr. 2013] Source-Python-Extensions
URL: http://forums.eventscripts.com/viewtopi ... 25&t=46657

Name: GunGame5.1
URL: http://wiki.gungame.net/pages/Installation

Let me know if there is any further information I can provide to assist with this.








SERVER.CFG

sv_region 1

hostname  "test"

rcon_password "*****"

sv_password "****"

mp_buytime 0

mp_startmoney 8000

mp_c4timer 30

mp_flashlight 1

mp_footsteps 1

mp_falldamage 1

mp_hostagepenalty 0

mp_timelimit 60

mp_winlimit 0

mp_maxrounds 0

mp_roundtime 9

mp_freezetime 2

mp_autoteambalance 1

mp_limitteams 1

mp_friendlyfire 0

mp_tkpunish 0

mp_autokick 1

mp_spawnprotectiontime 0

sv_timeout 600

mp_forcecamera 0

mp_allowspectators 1

sv_maxrate 8000

sv_minrate 1000

sv_maxupdaterate 60

fps_max 300

sv_voiceenable 1

sv_cheats 0

sv_pausable 0

mp_restartgame 0

sv_gravity 450

sv_airaccelerate 1000

sv_allowdownload 1

sv_allowupload 1

sv_downloadurl "****"

 




AUTOEXEC.CFG

plugin_load "addons/sp_extensions_ep2"

es_load gungame51

 
omnom

Recruit
Recruit
 
Posts: 2
Joined: Thu Aug 15, 2013 12:14 am

Postby omnom » Tue Aug 20, 2013 12:47 am

So this seems odd...

I added bot_quota 10 to my autoexec.cfg for testing and restarted my server about 20 times in a row, with NO adjustments to the config files or anything.

N = no crash
C = crash

N-N-C-N-C-C-N-N-C-C-N-C-C-N-N-N-N-N-C-C

so..wtf?

I compared the console logs from boot to end on a crash and a non crash, there was NO visible difference, other than:

PreMinidumpCallback: updating dump comment
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20130819182747_1.dmp

being at the end of the crashed log.


If the server loads successfully with bot_quota 10, I can rapidly change between bot_quota 0 and 10, adding and removing bots, without issue.
If the server loads successfully with bot_quota 10, I can rapidly change maps, without issue.

Would this mean the theory of bots loading on the same tic causing crashes be false, at least in this instance?

Are there other logs I could access to compare between crashed and noncrashed instances? Perhaps GG or ES specific logs?

I'd love to track down a cause since it appears to be random (as in I can go from no crash, restart, then crash with the EXACT SAME SETTINGS).



Any input appreciated.
Thanks!
omnom

Recruit
Recruit
 
Posts: 2
Joined: Thu Aug 15, 2013 12:14 am



Return to Troubleshooting (NOT FOR BUGS)

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron