installing gungame 5.1 Crash my server :(

Ask questions and share info about GunGame 5

installing gungame 5.1 Crash my server :(

Postby Legerarmy » Fri Oct 01, 2010 9:24 pm

Hi all.

I'm trying again to install gungame.
But my server crash at startup!
So I will tell you what i did.

I followd this staps to install my server.
http://www.srcds.com/db/engine.php?id=1098643920
I test the server. works great!

Now.
I follow this staps:
viewtopic.php?f=16&t=1369
I downloaded everything what the frist post sad..
Installed everything.

greated a autoexec.cfg:
mattie_eventscripts 1
eventscripts_subdirectory events

sv_allow_wait_command 1 // Required for EventScripts for the time being

stuffcmds // This is the line that fixes the IP issue & other strange issues
es_load gungame51


Now I start my server:
./server.sh

Then i get this:
[EventScripts] Loaded successfully.
ConVarRef room_type doesn't point to an existing ConVar
L 10/01/2010 - 17:43:14: server_cvar: "sv_accelerate" "5"
L 10/01/2010 - 17:43:14: server_cvar: "sv_stopspeed" "75"
Executing dedicated server config file
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient.dll. Continuing with current version anyway.
Installing breakpad exception handler for appid(srcds_linux)/version(1.0)
baseuser.cpp (431) : Assertion Failed: couldn't find entrypoint 'GetBaseUserDir'
/home/VALVE/rackadmin/buildslave/steam_rel_client_linux/build/src/clientdll/baseuser.cpp 431 Assertion Failed: couldn't find entrypoint 'GetBaseUserDir'
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
.
[EventScripts Version Check] Server is up-to-date.
L 10/01/2010 - 17:43:15: .
[EventScripts Version Check] Server is up-to-date.
L 10/01/2010 - 17:43:15: server_cvar: "sv_tags" "friendlyfire"
L 10/01/2010 - 17:43:15: server_cvar: "sv_tags" "friendlyfire"
L 10/01/2010 - 17:43:15: server_cvar: "sv_tags" "bots,friendlyfire"
L 10/01/2010 - 17:43:15: World triggered "Round_Start"
L 10/01/2010 - 17:43:15: "Steve<2><BOT><>" connected, address "none"
L 10/01/2010 - 17:43:15: "Steve<2><BOT><Unassigned>" joined team "CT"
Game will not start until both teams have players.
L 10/01/2010 - 17:43:15: "Steve<2><BOT><>" entered the game
L 10/01/2010 - 17:43:15: "Greg<3><BOT><>" connected, address "none"
L 10/01/2010 - 17:43:15: "Greg<3><BOT><Unassigned>" joined team "TERRORIST"
L 10/01/2010 - 17:43:15: World triggered "Game_Commencing"
L 10/01/2010 - 17:43:15: "Greg<3><BOT><>" entered the game
L 10/01/2010 - 17:43:15: "Xander<4><BOT><>" connected, address "none"
L 10/01/2010 - 17:43:15: "Xander<4><BOT><Unassigned>" joined team "CT"
L 10/01/2010 - 17:43:15: "Xander<4><BOT><>" entered the game
L 10/01/2010 - 17:43:15: "Dave<5><BOT><>" connected, address "none"
L 10/01/2010 - 17:43:15: "Dave<5><BOT><Unassigned>" joined team "TERRORIST"
L 10/01/2010 - 17:43:15: "Dave<5><BOT><>" entered the game
Server logging enabled.
L 10/01/2010 - 17:43:15: Log file closed
Server logging data to file logs/L1001019.log
L 10/01/2010 - 17:43:15: Log file started (file "logs/L1001019.log") (game "/home/public2/orangebox/cstrike") (version "4325")
L 10/01/2010 - 17:43:15: "Dan<6><BOT><>" connected, address "none"
L 10/01/2010 - 17:43:15: "Dan<6><BOT><Unassigned>" joined team "TERRORIST"
L 10/01/2010 - 17:43:15: "Dan<6><BOT><>" entered the game
L 10/01/2010 - 17:43:15: server_cvar: "bot_quota" "5"
L 10/01/2010 - 17:43:15: server_cvar: "bot_quota" "4"
L 10/01/2010 - 17:43:15: server_cvar: "gg_weapon_order_file" "default_weapon_order"
L 10/01/2010 - 17:43:15: server_cvar: "gg_weapon_order_sort_type" "#default"
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20101001174315_1.dmp
Installing breakpad exception handler for appid(srcds_linux)/version(1.0)
success = yes
response:  CrashID=bp-c99db8c2-4a35-4e59-afa1-8e4b22101001

./srcds_run: line 348:  5146 Segmentation fault      (core dumped) $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Fri Oct  1 17:43:17 CEST 2010: Server restart in 10 seconds
 


And he repeat the the hole time.

I got this system:
Linux Centos.

I hope somebody can help me?
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby satoon101 » Sat Oct 02, 2010 1:44 am

Do you have any other plugins installed? There are known crashes with Mani Admin and SourceMod, so if you have either installed on your server, make sure to check their sites for the fixes.

Satoon
satoon101

Site Admin
Site Admin
 
Posts: 1055
Joined: Thu Oct 09, 2008 4:27 pm

Re: installing gungame 5.1 Crash my server :(

Postby Legerarmy » Sat Oct 02, 2010 2:02 am

Nope.
Clean server.

I told you everything i did.
So from nothing, to a server.
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby satoon101 » Sat Oct 02, 2010 2:25 am

Try removing es_load gungame51 from your autoexec.cfg and manually load it after the server starts up (or, after you join the server with rcon es_load gungame51 in your client console). If that works, then try adding es_load gungame51 at the very bottom of your server.cfg.

Satoon
satoon101

Site Admin
Site Admin
 
Posts: 1055
Joined: Thu Oct 09, 2008 4:27 pm

Postby Legerarmy » Sat Oct 02, 2010 7:08 pm

I did remove es_load gungame51 fomr my autoexex.cfg, now my server is running good.
If i use "es_load gungame51" in console he crashes the server..

What to do?
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby XE_ManUp » Sun Oct 03, 2010 3:18 am

We don't even know if you have SPE installed. If so, you may want to try updating it.

Edit: I am aware you said you followed the instructions. No offense, but everyone says that, and in most cases, something is accidenly overlooked.
XE_ManUp

Site Admin
Site Admin
 
Posts: 662
Joined: Sat Sep 06, 2008 3:36 am

Postby Legerarmy » Mon Oct 04, 2010 4:44 pm

Yes i did.
now, i just downloaded for you again :p
and replaced the files.
Downloaded at:
http://forums.eventscripts.com/viewtopi ... 24#p269624

Now I started the server.
server is running well.
Now i'm going to try: es_load gungame51

result:
Crash!

I hope you can help me.
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby Legerarmy » Tue Oct 05, 2010 1:01 pm

Admins? Moderators?

Nobody can help me? :(
Why only me got this problem?
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby XE_ManUp » Tue Oct 05, 2010 5:42 pm

What is your server IP?
XE_ManUp

Site Admin
Site Admin
 
Posts: 662
Joined: Sat Sep 06, 2008 3:36 am

Re: installing gungame 5.1 Crash my server :(

Postby Legerarmy » Tue Oct 05, 2010 6:29 pm

Server IP: 193.104.186.78:27016
gungame is not loaded.
If I load it my server will crash
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby XE_ManUp » Thu Oct 07, 2010 5:16 am

Well, I just looked up your server. I don't see that Eventscripts is installed at all. This is a requirement for GunGame, unless you uninstalled it.
XE_ManUp

Site Admin
Site Admin
 
Posts: 662
Joined: Sat Sep 06, 2008 3:36 am

Postby Legerarmy » Thu Oct 07, 2010 6:36 am

then your looking wrong:

[EventScripts Version Check] Server is up-to-date.
Server logging enabled.
Server logging data to file logs/L1007038.log
L 10/07/2010 - 08:26:45: Log file started (file "logs/L1007038.log") (game "/home/public2/orangebox/cstrike") (version "4349")
L 10/07/2010 - 08:26:45: server_cvar: "sv_contact" "info@24-7gaming.nl"
L 10/07/2010 - 08:26:45: "Grant<2><BOT><>" connected, address "none"
L 10/07/2010 - 08:26:45: "Grant<2><BOT><Unassigned>" joined team "CT"
Game will not start until both teams have players.
L 10/07/2010 - 08:26:45: "Grant<2><BOT><>" entered the game
L 10/07/2010 - 08:26:45: server_cvar: "bot_quota" "1"
L 10/07/2010 - 08:26:45: server_cvar: "sv_tags" "bots,friendlyfire"
L 10/07/2010 - 08:26:45: server_cvar: "bot_quota" "4"
Cannot change maxplayers while the server is running
11
Installing breakpad exception handler for appid(srcds_linux)/version(1.0)
Server logging enabled.
L 10/07/2010 - 08:26:46: Log file closed
Server logging data to file logs/L1007039.log
L 10/07/2010 - 08:26:46: Log file started (file "logs/L1007039.log") (game "/home/public2/orangebox/cstrike") (version "4349")
L 10/07/2010 - 08:26:46: "Gary<3><BOT><>" connected, address "none"
L 10/07/2010 - 08:26:46: "Gary<3><BOT><Unassigned>" joined team "TERRORIST"
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20101007082646_1.dmp
success = yes
response:  CrashID=bp-999c05a0-5a95-435c-a737-1bcaa2101006

./srcds_run: line 348: 23098 Segmentation fault      (core dumped) $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Thu Oct  7 08:26:47 CEST 2010: Server restart in 10 seconds

 
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby XE_ManUp » Thu Oct 07, 2010 7:30 pm

http://www.game-monitor.com/cstrike2_Ga ... ables.html

That is what I see for your game server. Is that correct?
XE_ManUp

Site Admin
Site Admin
 
Posts: 662
Joined: Sat Sep 06, 2008 3:36 am

Postby Legerarmy » Fri Oct 08, 2010 12:25 am

yes, but you can't see eventscript?


es_load

[EventScripts] Loaded:
[EventScripts]   [ enabled] corelib
[EventScripts]   [ enabled] corelib/testlib
[EventScripts]   [ enabled] corelib/interfaces
[EventScripts]   [ enabled] corelib/linkedlist
[EventScripts]   [ enabled] corelib/repeat
[EventScripts]   [ enabled] corelib/score
[EventScripts]   [ enabled] corelib/xalias
[EventScripts]   [ enabled] corelib/textlib
[EventScripts]   [ enabled] corelib/playergetset
[EventScripts]   [ enabled] corelib/getbotname
[EventScripts]   [ enabled] corelib/damage
[EventScripts]   [ enabled] corelib/playervar
[EventScripts]   [ enabled] corelib/sqlitelib
[EventScripts]   [ enabled] corelib/statlog
[EventScripts]   [ enabled] corelib/quickcmd
[EventScripts]   [ enabled] corelib/queue
[EventScripts]   [ enabled] corelib/vecmath
[EventScripts]   [ enabled] crontab
[EventScripts]   [ enabled] corelib/services
[EventScripts]   [ enabled] corelib/foreach
[EventScripts]   [ enabled] corelib/average
[EventScripts]   [ enabled] corelib/keyfilter
[EventScripts]   [ enabled] corelib/uniqueid
[EventScripts]   [ enabled] corelib/timelib
[EventScripts]   [ enabled] corelib/keygroupsort
[EventScripts]   [ enabled] corelib/keygrouprand
[EventScripts]   [ enabled] corelib/keyrand
[EventScripts]   [ enabled] corelib/exp
[EventScripts]   [ enabled] corelib/isnumerical
[EventScripts]   [ enabled] corelib/escinject
[EventScripts]   [ enabled] corelib/getplayercount
[EventScripts]   [ enabled] corelib/usermsglib
[EventScripts]   [ enabled] corelib/inrange
[EventScripts]   [ enabled] corelib/entitylib
[EventScripts]   [ enabled] corelib/es_install
[EventScripts]   [ enabled] corelib/es_checkversion
[EventScripts]   [ enabled] corelib/es_mexec
[EventScripts]   [ enabled] corelib/clientcmd
[EventScripts]   [ enabled] popup
[EventScripts]        name: Popup library wrapper
[EventScripts]     version: oy29
[EventScripts]         url: http://www.eventscripts.com/pages/Popup/
[EventScripts]      author: GODJonez + ES 2.0 Beta Test team
[EventScripts]    description: Provides menu and pop-up handling for Source games
[EventScripts]    basename: popup
[EventScripts]   [ enabled] keymenu
[EventScripts]   [ enabled] vote
[EventScripts]------------------------
*** EventScripts caught an exception:
Traceback (most recent call last):
  File "/home/public2/orangebox/cstrike/addons/eventscripts/es.py", line 276, in tick
    x()
  File "/home/public2/orangebox/cstrike/addons/eventscripts/_libs/python/gamethread.py", line 169, in tick
    first = timeq.getFirst()
  File "/home/public2/orangebox/cstrike/addons/eventscripts/_libs/python/gamethread.py", line 43, in getFirst
    def getFirst(self):

*** EventScripts caught an exception:
Traceback (most recent call last):
  File "/home/public2/orangebox/cstrike/addons/eventscripts/es.py", line 276, in tick
    x()
  File "/home/public2/orangebox/cstrike/addons/eventscripts/_libs/python/gamethread.py", line 169, in tick
    first = timeq.getFirst()
  File "/home/public2/orangebox/cstrike/addons/eventscripts/_libs/python/gamethread.py", line 43, in getFirst
    def getFirst(self):
KeyboardInterrupt

 


i also tried to install gungame4 also faild.. but i geuss its not orangebox
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby Legerarmy » Sun Oct 10, 2010 1:27 am

omg? no support?
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Postby XE_ManUp » Sun Oct 10, 2010 7:20 am

Well, it looks like you have GunGame4 installed now, am I correct? Before, EventScripts was not showing as installed on your server. I wasn't able to install it for you!

You should be able to install 5.1 now - so long as you have SPE installed as well.
XE_ManUp

Site Admin
Site Admin
 
Posts: 662
Joined: Sat Sep 06, 2008 3:36 am

Postby Legerarmy » Mon Oct 11, 2010 6:45 pm

@johnyx
dude Create your own post o.O

@helpers
But, i only placed gungame4 and load it but it even diddn't load.
So only I need to do is es_load gungame51 but then the server crasht...
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Re: installing gungame 5.1 Crash my server :(

Postby johnyx » Mon Oct 11, 2010 6:49 pm

ops sory i dont know about gg4 i create new post sry again
johnyx

Private
Private
 
Posts: 8
Joined: Tue Jun 01, 2010 7:21 am
Steam Friends Name: sekarus

Postby satoon101 » Mon Oct 11, 2010 6:55 pm

No need, I have split his topic off into it's own thread.

Satoon
satoon101

Site Admin
Site Admin
 
Posts: 1055
Joined: Thu Oct 09, 2008 4:27 pm

Postby Legerarmy » Tue Oct 12, 2010 8:09 pm

ok but now support....?
Legerarmy

Private
Private
 
Posts: 20
Joined: Fri Oct 01, 2010 8:58 pm

Next


Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 5 guests

cron